Outage: Card payment processing

Major incident Payment processing
2021-09-17 16:41 UTC · 1 hour, 50 minutes, 43 seconds

Updates

Resolved

The issue has been resolved and Card Payments are now being processed. For more information please contact our support department or your account manager.

September 17, 2021 · 18:31 UTC
Issue

We have detected an issue with Card transaction processing on our technical supplier’s side. We are currently investigating the issue with our partner, we’ll update you soon.

September 17, 2021 · 16:46 UTC

← Back