Payment processing is currently down

Major incident Payment processing
2021-12-16 09:00 UTC · 18 minutes

Updates

Resolved

Payment processing is up

December 16, 2021 · 09:19 UTC
Issue

Our payment processing is currently down. We are investigating and working on fix.

December 16, 2021 · 09:01 UTC

← Back